Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Makefile PATH modification with -current 'make'?

On Wed, 15 Feb 2017, John D. Baker wrote:

> On Tue, 14 Feb 2017, Simon Gerraty wrote:
> > which AFAICT behaves as expected (current make on 7/amd64 and 7/i386)
> I've not tried running 'make' from -current on NetBSD-7.

I just copied "/usr/bin/make" from a -current/amd64 system to a
netbsd-7/amd64 system.  It seems to operate, but it produces the same
failure when trying to build "/usr/pkgsrc/wip/moto4lin".

Conversely, after copying the saved "/usr/bin/make" from the netbsd-7/amd64
system to the -current/amd64 system, I can build "/usr/pkgsrc/wip/moto4lin"
successfully.  'make' seems a bit sluggish, but works.

The problem with -current 'make' only showed up when I tried to build
"/usr/pkgsrc/wip/moto4lin".  Prior to that, I built all packages in my
usual complement without incident (modulo pkg/51266).

My -current/i386 system is engaged building "libreoffice", so it will
be some time before I can test the same 'make' transplant on it.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index