Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: How to enter ddb on recent NetBSD/amd64 current

On Thu, 16 Jul 2015, Michael van Elst wrote:

On Thu, Jul 16, 2015 at 04:09:48PM +0100, Patrick Welche wrote:

# grep console var/run/dmesg.boot
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation)
wskbd0 at pckbd0: console keyboard, using wsdisplay0

My system reports:

#  grep console /var/run/dmesg.boot
wsdisplay0 at intelfb0 kbdmux 1: console (default, vt100 emulation)
wskbd0 at ukbd0: console keyboard, using wsdisplay0

Even though I have a pckbc and pckbd configured, and it finds a pckbc0 device, my system never attaches a pckbd:

# config -x | grep -e PCKB -e pckb
# don't attach pckbd as the console if no PS/2 keyboard is found
pckbc0          at isa?                 # pc keyboard controller
pckbd*          at pckbc?               # PC keyboard
wskbd*          at pckbd? console ?
pms*            at pckbc?               # PS/2 mouse for wsmouse
# grep pckb /var/run/dmesg.boot
pckbc0 at isa0 port 0x60-0x64

In a wave of optimism, I tried ctl-alt-esc, and nothing. Also
tried setting hw.cnmagic to ^K, and no still ddb.

Any more things to try?

Do you really believe you have a working pckbd now?

                               Michael van Elst
                               "A potential Snark may lurk in every tree."

| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:       |
| (Retired)        | FA29 0E3B 35AF E8AE 6651 | paul at    |
| Kernel Developer | 0786 F758 55DE 53BA 7731 | pgoyette at  |

Home | Main Index | Thread Index | Old Index