Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: continuous crashing 5.99.39

2010/10/5 Juergen Hannken-Illjes <>:
> On Tue, Oct 05, 2010 at 10:27:05AM +0200, Jens Rehsack wrote:
>> Hi,
>> every night when I load my iPod on my NetBSD laptop, the machine is rebooted
>> at the next morning, This happens now 4 times, I rate this as a
>> pattern meanwhile.
>> But there are no cores available at the morning.
>> But today, when I was going to start X, it dumps (see gdb.txt).
>> I tried to "vi gdb.txt" before sending, and it crashs again (but it
>> doesn't crash when
>> doing gdb, mount, fsck, cp, ...). The backtraces of the dumps are
>> attached in vi1.txt
>> and vi2.txt.
>> Is there anything I can try? Currently I assume the last iPod crash
>> corrupts something
>> and a rebuild/reinstall of the base system hopefully solves it.
> [snip]
>> #1  0xffffffff8044403d in panic (
>>     fmt=0xffffffff805c3ca0 "ffs_valloc: dup alloc")
>>     at /usr/src/sys/kern/subr_prf.c:302
> At least one of your file systems is corrupt.  Any errors from fsck while
> booting?

Well, I checked the /var/log/messages and /var/run/dmesg.log, nothing in
there. Than I rebooted (shutdown -r now) and booted in single user mode,
doing an fsck -y (reported all ffs filesystems are clean) and a
fsck -y /dev/rwd1e (my ext2 shared disk for data exchange between NetBSD
and Linux and Win32). This volume was not clean unmounted (as usual after
a crash, but no errors).

After all filesystems were marked clean, I continued the boot process and
tried again to vi one of above text files. Same panic, same backtrace.


Home | Main Index | Thread Index | Old Index