Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [5.0_RC3] amd64 dom0 hangs during boot on Dell Optiplex 745

Hi there,

On Thu, 02 Apr 2009 12:29:06 -0400
Marko Schütz <> wrote:

> I have a Dell Optiplex that boots a NetBSD/amd64 kernel built from
> 5.0_RC3 sources with azalia* disabled just fine. Booting a NetBSD/xen
> kernel built from the same sources (also with azalia* disabled) hangs
> the machine. The last message on the console is 
> atapibus0 at atabus1: 2 targets
> cd0 at atapibus0 drive 0: <TSSTcorp CD-RW/DVD-ROM TS-H493A, , D200>
> cdrom removable
I have the same issue.

> If I disable ehci NetBSD/xen boots.

disabling uhci/ohci NetBSD will boot too. But there will be a strange
message in dmesg:

| ehci1: strange port

Besides booting with a normal GENERIC kernel won't work. Booting with
azalia disabled everything works fine.. except: The internal Broadcom
NIC disables ehci while getting active. wtf?
The Broadcom NIC is on a completly different PCI Bus..

/netbsd: azalia0: interrupting at ioapic0 pin 16
/netbsd: bge0: interrupting at ioapic0 pin 16
/netbsd: uhci0: interrupting at ioapic0 pin 16

All of them are on one interrupt. I doubt that's okay and even with 
"options PCIFIXUP" it's not better.

Today's afternoon I'll try to analyse it a bit. Maybe someone has some 
recommendations what I should look for.

best regards,
Frederic Jaeckel

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index