Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: can't run as root with netbsd-5

Hash: SHA1

On Tue, 3 Mar 2009, Eric Haszlakiewicz wrote:

> I just tried upgrading one of my machines to netbsd-5.  The process seemed to
> go ok on a test machine, and when I tried it on another machine it started
> out ok, but now I can't run things as root.  Specifically:
>   I copied a netbsd 5 RC2 generic kernel and rebooted. (previously running
>        netbsd 4)
>   After rebooting, I was able to login and run stuff as root just fine.
>   I was going to let it run for a bit and then upgrade userland, but
>    now when I attempted to su to root to do so I get errors like:
> su: /bin/ksh: Resource temporarily unavailable
>   I can use sudo to switch to other users, and running most things seems
> to be fine, but actually executing stuff as root from a setuid process
> fails.  Things that are already running, like apache, seem to be ok, and
> the root owned apache process can fire up additional www owned processes.

I've seen this as well, I got it from upgradeing from

I suspected something to do with login.conf or other per user
limits stuff. When it wasn't working i had > 80 root owned processes, but
that wasn't near the 16/128 etc proc limits. It did allow root logins again
after many root processes had been killed off but i can't remember exact
figures. I didn't have time to look into it further and got hampered a bit
by PR/40314

I'll look again tommorow if i get a chance.

- -- 
[]                                   [0x2ECA0975]
Version: GnuPG v1.4.9 (NetBSD)


Home | Main Index | Thread Index | Old Index