Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

can't run as root with netbsd-5

I just tried upgrading one of my machines to netbsd-5.  The process seemed to
go ok on a test machine, and when I tried it on another machine it started
out ok, but now I can't run things as root.  Specifically:
  I copied a netbsd 5 RC2 generic kernel and rebooted. (previously running
         netbsd 4)
  After rebooting, I was able to login and run stuff as root just fine.
  I was going to let it run for a bit and then upgrade userland, but
   now when I attempted to su to root to do so I get errors like:

su: /bin/ksh: Resource temporarily unavailable

  I can use sudo to switch to other users, and running most things seems
to be fine, but actually executing stuff as root from a setuid process
fails.  Things that are already running, like apache, seem to be ok, and
the root owned apache process can fire up additional www owned processes.

  I would just reboot the machine, but I don't currently have easy
physical access to it.

 Does anyone have any suggestions?


Home | Main Index | Thread Index | Old Index