Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: can't run as root with netbsd-5

On Tue, Mar 03, 2009 at 10:09:34PM -0600, Eric Haszlakiewicz wrote:

> I just tried upgrading one of my machines to netbsd-5.  The process seemed to
> go ok on a test machine, and when I tried it on another machine it started
> out ok, but now I can't run things as root.  Specifically:
>   I copied a netbsd 5 RC2 generic kernel and rebooted. (previously running
>        netbsd 4)
>   After rebooting, I was able to login and run stuff as root just fine.
>   I was going to let it run for a bit and then upgrade userland, but
>    now when I attempted to su to root to do so I get errors like:
> su: /bin/ksh: Resource temporarily unavailable
>   I can use sudo to switch to other users, and running most things seems
> to be fine, but actually executing stuff as root from a setuid process
> fails.  Things that are already running, like apache, seem to be ok, and
> the root owned apache process can fire up additional www owned processes.
>   I would just reboot the machine, but I don't currently have easy
> physical access to it.
>  Does anyone have any suggestions?

I think it's a bug where _your_ process limit is considered at some point,
regardless of the fact that the binary is suid/sgid. I can't remember the
exact details, including at what point it occurs. If you sprinkle printfs to
find out where the error is coming from, and what the various credentials
involved are, we should be able to figure out what to do.


Home | Main Index | Thread Index | Old Index