Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Keeping Compatibility - yes please!

[ source-changes elided from the CC ] 

On Thu, Jan 22, 2009 at 05:22:53PM +0700, Robert Elz wrote:
  |   [...]
  | NetBSD's current compatibility policy is important, we need to keep it,
  | even strengthen it wherever possible (mostly by gradually redesigning those
  | interfaces that turn out to cause problems to make them more stable).
  | Weakening it would be a disaster.

I completely agree with Robert's entire post; especially this last point.

Our ABI compatibility offering, especially with newer kernels and
older userland [*] has been one of our stronger features for years,
in contrast to the problems that are experienced on other (open source)
systems that don't care about ABI compatibility.


[*] modulo annoying exceptions such as ipfilter.
    darrenr@, please fix this correctly.
    mrg@ & I (and others) have been on your case about
    this for at least a decade.

Attachment: pgpbpPQsXrRt_.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index