Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

ath0: device timeout

I'm after ideas... I have an otherwise mostly stable netbsd-4 box
with an ath0 card running hostap for my home network. I recently got
a Android G1 phone, and since getting it, my MacBook Pro laptop
(OS X) frequently times out wireless connections (eg. ssh). It might
be 2 minutes, it might be an hour.  Meanwhile, an ssh session from
the G1, attached to the same screen session is fine. If I turn the
wireless off on the G1, the laptop stays connected fine.

Whenever the laptop times out, I get "ath0: device timeout" to syslog,
although connections from the G1 are fine. It's usually a while before
even pings from the laptop come through. I've captured some of the
timeouts with debug enabled on the interface - log is available to
anyone that wants to take a look.

The card is:
ath0 at pci2 dev 11 function 0
ath0: interrupting at ioapic0 pin 23 (irq 11)
ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 
36Mbps 48Mbps 54Mbps
ath0: mac 7.9 phy 4.5 radio 5.6

$ ifconfig ath0
        ssid xxxxxxxx apbridge nwkey *****
        powersave off
        bssid 00:1b:11:17:6b:70 chan 7
        address: 00:1b:11:17:6b:70
        media: IEEE802.11 autoselect mode 11g hostap
        status: active
        inet netmask 0xffffff80 broadcast
        inet6 fe80::21b:11ff:fe17:6b70%ath0 prefixlen 64 scopeid 0x3

Kernel is:
NetBSD 4.0_STABLE NetBSD 4.0_STABLE (ZION) #0: Sun Jan 11 
00:17:44 EST 2009

Paul Ripke
I love deadlines. I like the whooshing sound they make as they fly by.
-- Douglas Adams

Home | Main Index | Thread Index | Old Index