Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: panic: ffs_valloc: dup alloc

On Sun, 18 Jan 2009 16:37:20 +0100
Tobias Nygren <> wrote:

> On Sat, 10 Jan 2009 12:20:12 +0100
> Lars Nordlund <> wrote:
> > Hi
> > 
> > Hand-copied from screen:
> > 
> > dmode 8000 mode 8000 dgen 504d64d6 gen 504d64d6
> > size 0 blocks 0
> > ino 3 ipref 8
> > panic: ffs_valloc: dup alloc
> > fatal breakpoint trap in supervisor mode
> > trap type 1 code 8 eip c02369c4 cs eflags 246 cr2 bbb99660 ilevel 8
> > Stopped in pid 5416.1 (mkdir) at   netbsd:breakpoint+0x4: popl %ebp
> > 
> > This happened on NetBSD-current from 2009-01-08 on my i386 UP machine
> > while building some stuff from pkgsrc.
> > 
> > For some reason NetBSD can not boot with a PS2 keyboard attached, so I
> > can not do anything at the moment at the ddb-prompt. I suppose
> > crashdump is the only way forward.
> > 
> > Anyone else seeing this?
> I saw this consistently today while trying to untar files on a newly
> created ffs -O2 filesystem after booting a current NetBSD/alpha sysinst
> kernel. Note I am *not* using WAPBL. The fix for me was to mount the
> filesystem with -o sync while untarring. I've not been able to reproduce
> the panic so far after rebooting into the newly installed system,
> although I did see signs of fs corruption (a corrupt directory).
> Will try to krank up debugging options.

I never got the previous installation to fly. I had to reinstall.

I had created separate filesystems (/, /var, /usr and /home) and /usr
was constantly giving me problems. Trying to access some files
under /usr/share would sometimes reboot the machine. The panic message
in the core dump had a message 'bad dir' (or something).

In single-user mode, I copied away everything from /usr and newfs:ed
(FFSv2), mounted (tried with and without WAPBL), and copied files back.
Then I could not umount! The umount command would just freeze.. When
looking in ddb I could not say if something was really broken or just
very inefficient/slow. I let it run a long time, but it never finished
the umount. Hard reset was necessary.

One theory I had was that something previously written on the hard
drive confused the kernel in some way.. I tried zeroing the partition
before newfs:ing, but that did not help. The same, hanging umount kept
coming back like a bad breath.

So I thought.. Everyone is using OneBigRoot(TM) these days.. Lets try
that. I had done very little on the problematic installation anyway. I
reinstalled, did the same as before, cvs checkout pkgsrc, start some
builds, configure X, get things configured and running .. and everything
seems to work fine now. No panics.

At the moment I am a bit short on spare computers, so I can not test
installations for some time.

Best regards,
        Lars Nordlund

Home | Main Index | Thread Index | Old Index