Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: versioned files in DESTDIR breaking build

On Thu, Jul 10, 2008 at 02:20:37PM +0200, Havard Eidnes wrote:
> > > When we move to 4.99.68, you'll have an old 4.99.67 directory that
> > > will need cleaning.
> >
> > Exactly, so I'm suggesting that the build procedure should be changed so
> > this doesn't happen.  Presumably all these files are getting added to
> > the obsolete sets list so poinstall fix can remove them; perhaps that
> > should be run on destdir.
> The old modules are not fixed up by postinstall, and they
> probably should not be either...

The tools infrastructure has logic to calculate whether the tools need
to be rebuilt or not, and (some of) that is based on __NetBSD_Version__,
so it should be possible to work out whether the modules are out of date.


Home | Main Index | Thread Index | Old Index