Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cant install amd64 4.99.63 due to device busy errors

On Mon, May 26, 2008 at 11:36:53AM +0100, Mark Kirby wrote:
> Hi,
> Im trying to install amd64 4.99.63 on my macbook, when i use sysinst it 
> gets to the point of newfsing the partition but dies complaining the 
> device is busy. So i tried a 4.99.22 installer which worked first time 
> without any problems.
> After installing i inserted the 4.99.63 cd and tried to upgrade, same  
> thing device busy. Copying the new kernel of the cd and booting just  
> ends with
> vfs_mountroot: can't open root device
> cannot mount root, error = 16
> and 16 is EBUSY
I just had the very same problem when trying to install 4.99.64 on a
macbook. Installing 4.0 on this machine went fine.

> Any one got any ideas? Should i file a PR?                                    
I noticed the 4.99.64 install kernel did see the gpt partitions, and
recognized only the EFI one, which is fat32. The HFS+ ones were
skipped/ignored. sysinst tried to use the mbr partitions proposed by
rEFIt, and proposed to partition a mbr slice. Everyting went fine until
it tried to newfs, which failed with "device busy". Mounting the
partitions that the 4.0 installed made also failed with the same error.

Could it be that the gpt wedge support prevents the use of the mbr ?
Then it would be nice to have the gpt tool in the install kernel, to be
able to change some gpt labels to some that netbsd understands.
I will ty to test a -current install kernel built without the


Attachment: pgpEZN209_jsH.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index