Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cant install amd64 4.99.63 due to device busy errors

On 23 Jun 2008, at 16:35, wrote:
Any one got any ideas? Should i file a PR?
I noticed the 4.99.64 install kernel did see the gpt partitions, and recognized only the EFI one, which is fat32. The HFS+ ones were skipped/ignored. sysinst tried to use the mbr partitions proposed by rEFIt, and proposed to partition a mbr slice. Everyting went fine until it tried to newfs, which failed with "device busy". Mounting the partitions that the 4.0 installed made also failed with the same error.

Could it be that the gpt wedge support prevents the use of the mbr ? Then it would be nice to have the gpt tool in the install kernel, to be able to change some gpt labels to some that netbsd understands. I will ty to test a -current install kernel built without the DKWEDGE_AUTODISCOVER and DKWEDGE_METHOD_GPT options.

Thanks that did the trick, turning of the wedges stuff got it installed.

Now just need to work out why X freezes every 5 minutes.


Home | Main Index | Thread Index | Old Index