Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: (amd64) panic: mpacpi_findintr_linkdev: irq mismatch

On Dec 28, 2007, at 5:18 AM, D'Arcy J.M. Cain wrote:

On Thu, 27 Dec 2007 23:12:52 -0800
Alex Hanson <> wrote:
After upgrading to netbsd-current/amd64 I experienced a kernel panic
upon boot. My experience is exactly the same as this one:
(sorry if that is not the preferred way of referencing other messages)

I thought it would be more appropriate on this list.

Enabling mp_verbose gives this error description:
linkdev ALKA returned ACPI global int 1
I do not know what to look for from here.

I made the following changes.  The first is just to get more detail
after setting mp_verbose.  The second is the thing that allows me to
run NetBSD on my amd64. jmcneil@ is working on a proper fix but so far
I have not had any problems running this kernel.

I'm seeing this same error on boot. I've got an EPIA Mini-ITX EN15000g board with a SATA pci card in it. Current from November runs fine, but current from a couple of days ago has this same panic:
    panic: mpacpi_findintr_linkdev: irq mismatch
with setting MP_verbose:
        linkdev ALKA returned ACPI global int 1

I captured the acpi info with this:
    acpidump -o EN15000g.dsdt > EN15000g.asl
it's available here:

I can try D'Arcy's change and see if that fixes it for me, but I was wondering if there's been any progress on the "proper fix" that jmcneil is supposed to be working on.



Robert Thille                7575 Meadowlark Dr.; Sebastopol, CA 95472
Home: 707.824.9753    Office/VOIP: 707.780.1560     Cell: 707.217.7544   YIM:rthille

Home | Main Index | Thread Index | Old Index