Port-i386 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Accidentally "upgraded" i386 to amd64

On Wed, Dec 2, 2020 at 8:53 AM David Young <dyoung%pobox.com@localhost> wrote:
> The same warning tormented me for the longest time.  I figured out
> how to fix it just the other night.
> First, I searched the `pkg_info -aB` output for i386.  That showed
> me that I had both pkg_install-20101122 and pkg_install-20200701
> registered as installed.  The former was built for i386, and the
> latter for amd64.  You may find that your system is in a similar
> state.
> I could find no i386 executables on my system:
> the pkg_install-20200701 content had overwritten the pkg_install-20101122 binaries.
> Since pkg_install-20101122 is used for installing packages, and
> it was the *only* package built for i386, I guessed that the mere
> fact that it was registered was the problem.
> It took a little while to figure out an incantation that would
> remove pkg_install-20101122 without erasing any pkg_install-20200701
> content, since that would leave my system in a bad state.  Complicating
> matters, both versions of pkg_install were registered as must-not-delete
> packages.
> I thought `pkg_delete -fN pkg_install-20101122` looked like a safe
> candidate.  I tried it.  It worked.  No more warnings.
> Maybe my fix will work for you.  It will be inconvenient if you
> end up without any pkg_install whatsoever, so proceed cautiously.

I only have an i386 pkg_install version according to this. I have
tried to install a new pkg_install from the amd64 packages and it
won't install.

Somehow I need to find out how to upgrade this package. Still looking.



Home | Main Index | Thread Index | Old Index