Port-hpcmips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NEC MobilePro 780 & 790 Resume Issues

Disclaimer is I haven't tested it thoroughly because I didn't want to commit too much time without having the sleep issue resolved since my intention was to use the device on the road for note taking, remote terminal, etc.  I got a few core dumps from time to time and the installer didn't work on the release version (but installing manually to a CF from a host machine was fine and easy enough that I didn't even bother with the installer after the cross compile).

From the cross compiling perspective, I've found over the years that the most reliable way to do this is with separate object/dest/release directories for each architecture you build on a given box.

For example:  ./build.sh -j2 -u -x -M /usr/obj.hpcmips -D /usr/dest.hpcmips -T /usr/tools -R /usr/release -m hpcmips release

If I get a minute sometime in the near future I'll try and see if I can figure out what's broken.


On Mon, Nov 12, 2018 at 6:50 AM Doug Barry <douglas.barry%gmail.com@localhost> wrote:
Last time I had suspend/resume working was back on NetBSD 5.

I've resigned myself to leaving mine powered, but with screen blanking. Though I use them as permanently powered terminals on my desk, not in a portable configuration.

I've not tried NetBSD 8 yet. Did you do anything special when you cross compiled?


Doug Barry

On Fri, Nov 9, 2018 at 2:02 AM Jesse Darrone <jrd321%gmail.com@localhost> wrote:

After much fiddling I've been unable to get resume for the MobilePro 780/790 working on NetBSD 8.  I've cross compiled netbsd-8 from CVS and I've got the system running pretty well from the command line, but any suspend method I've tried via either the apm command or the power/suspend button results in the machine going to sleep and unable to wake without a hard reset.

Has anyone been down this particular rabbit hole before?


Home | Main Index | Thread Index | Old Index