Port-hpcmips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Workpad Z50 install issue

On 27 March 2015 at 22:59, Larry Stotler <larrystotler%gmail.com@localhost> wrote:
> Greetings.
> I recently acquired a pristine Z50 with the 32MB RAM upgrade.
> everything seems to work with no issues.  I've been using Linux for 16
> years, but have little experience with NetBSD and am looking forward
> to learning.

Nice little hpcmips box :)

> I have a 2GB Compact Flash card that I split in half, first half for
> FAT16 and the rest for NetBSD.  I'm using a 3COM Etherlink III 10BaseT
> network card.
> I tried installing NetBSD from the dos partition but could not figure
> out how to mount it.  So,
> I tried installing over NFS.  It started installing but when I get to
> the base.tgz package, it fails.  So, thinking there might be an issue
> with the iso I downloaded,
> I am now trying to install via FTP.  The first 2 packages have
> installed, but it is still failing on base.tgz.
> The error I am now getting is:
> zip: data stream error
> tar: End of archive volume 1 reached
> tar: Unexpected EOF on archive file
> at 20%.  I was getting a different error but now can't duplicate that one.
> Could the CF card be bad?  I'm probably going to get a newer card
> and/or a microdrive as well.

Its *possible*, or it could be an issue with the machine or NetBSD.
What NetBSD version are you trying? To see if it could be a NetBSD
issue which has been fixed you might want to try netbsd-7 (beta)
http://nyftp.netbsd.org/pub/NetBSD-daily/netbsd-7/ or current

Another option to test if you have nfs working is to extract the sets
on the NFS server and then just point the root filesystem to the nfs

> Any suggestions would be greatly appreciated.
> Also, can anyone suggest a really good guide for using NetBSD and/or
> how it differs from Linux?  I find myself trying Linux commands that
> don't work under BSD and don't have any idea what the equivalents are.
> Like:
> cat /proc/cpuinfo
> cat /proc/meminfo

sysctl hw|less has some info, as does cpuctl identify 0 and my quick &
dirty favourite 'less /var/run/dmesg.boot' (or dmesg|less after boot)

> Netbsd drive structure vs Linux's sdx

NetBSD typically has wd[number][letter] for IDE/SATA drives and
sd[number][letter] for SCSI drives. the number is the drive number,
starting from 0 and letter is the partition, starting from 'a' with
'c' being the entire disk (or 'd' on x86 for historical reasons)

Home | Main Index | Thread Index | Old Index