pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cannot print to printer (lpr, a2ps) with "gnumeric112"

On Wed, 11 Jul 2018, John D. Baker wrote:

> I don't know if this is related to the "cups" discussion, but in my
> first attempt to print from "gnumeric112" since updating, I find that
> it will not print to my printer.

Fun with paper sizes.  Since these were new spreadsheets I'd just created,
"gnumeric" defaulted to "A4" and apparently the printer discarded the
job since there was no paper of that size in any tray (HP 4100mfp).
(Or maybe it has them cached, waiting for a tray to be loaded with A4
size paper?)

Using the Page Setup options and setting the size to "US Letter" (and
changing units accordingly), the spreadsheets now print on my printer.

Annoying that even checking "save as defaults" will not actually save
these settings for the next time a new spreadsheet is opened.  Each time
I run 'gnumeric' I get the following on the terminal where I ran

  GLib-GIO-Message: 16:52:04.997: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

Now I know they mean business.

Also, that means the PDFs I generated were sized for A4, yet printing
from both 'evince' and 'xpdf' succeeded in printing on US letter-size

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index