NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkgin does not install anything after upgrade to 9.2

Hi Greg,

Thanks for your suggestions! It indeed seems to be corrupted :( I tried to nuke (rm -rf) the directory

/usr/pkg/pkgdb/p5-Net-SSLeay-1.88nb1 but I got back that the directory is not empty which is pretty unusual for rm -rf. Now, when I try to list its contents, three files are shown:


However, when listing with ls -al, I get the error:

ls: +COMMENT: No such file or directory

ls: +CONTENTS: No such file or directory

ls: +DESCR: No such file or directory

I tried to execute fsck for the node number (fsck 35752122) of the directory but I got back:

fsck: cannot open '/dev/35752122': No such file or directory

Is there any solution for this?

Best regards,


On 7/8/21 7:26 PM, Greg Troxel wrote:
r0ller <> writes:
The only error I see in pkg_install-err.log (which is not shown as error) which seems to block each pkg install is: pkg_admin: Cannot read +CONTENTS of package p5-Net-SSLeay-1.88nb1 Does anyone have any hint?
pkg_admin rebuild-tree pkg_admin check make sure your variables in mk.conf are set to point to your pkgdb. See and set the variables even if you think it's not necessary. look in /usr/pkg/pkgdb/p5-Net-SSLeay-1.88nb1 and see if there is indeed no +CONTENTS. If true, you have had some corruption and I would rm -rf the p5-Net-SSLeay-1.88nb1 directory, and then you'll have to reinstall it.

Home | Main Index | Thread Index | Old Index