NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD on Dedibox SC Gen2

----- Le 20 Sep 15, à 12:11, Manuel Bouyer a écrit :

> Hello,
> for the record here is a short howto install NetBSD on Dedibox SC Gen2.


I ordered two of these machines a few weeks ago, and installed them using
another way : I first installed a Linux distribution, then asked the
support team for a virtual KVM, which uses VNC (access is granted for 12 hours). 
I copied a NetBSD 7.0 amd64 installation kernel in /boot, then booted on this kernel
using the bootloader (in my case, I used Grub 2, you can find some 
instructions to boot NetBSD from the Grub shell here : ).

The only difficulty I had using this way was the keyboard. It looks like it was
disconnected from time to time. Using the local console for first setup tasks
showed me the following error messages :

ukbd0: was console keyboard
wskbd0: detached
ukbd0: detached
uhidev0: detached
uhidev0: at uhub0 port 1 (addr 2) disconnected
wsmouse0: detached
ums0: detached
uhid0: detached
uhid1: detached
uhidev1: detached
uhidev1: at uhub0 port 1 (addr 2) disconnected
uhub0: device problem, disabling port 1
uhub0: device problem, disabling port 1

I can clearly live with it, since the KVM is only used for installations and 
for first tasks. However, I experienced freezes on these two machines : there
is no answer to a ping or ssh, and I get no display from the console
(but I suppose this is related to the KVM problem).
I usually experience these freezes on heavy tasks : 
- a partial chrooted pbulk build ( around 700 packages) ;
- compiling some packages with pkgsrc, perl and git for instance.

I cannot reproduce the freezes precisely, since they don't appear
at the exact same moment. I tried to stress one of the servers using
benchmarks/blogbench : it handled a load average of 109 for more than 2 hours
and 45 minutes, and I still could type commands in the ssh session.
I also tried net/iperf3 in case the culprit was network related, without success.

Lately, freezes do not seem to be load related : one happened when
I rsync'ed (over ssh) to the server the content of a partial pbulk build,
and I got another freeze with only irssi/tmux running
(I can only suppose there was not something else, since I have no crash log).

I tried the following :
- booted without ACPI ;
- booted without SMP and without ACPI ;
- booted a NetBSD 7-stable kernel (201510201750) ;
- booted a NetBSD current kernel (201510201750) ;
- added and removed log mount option in fstab ;
- added and removed noatime mount option in fstab.

I used blogbench and iperf3 with 7.0.

Does someone have an idea on this ?

Nils Ratusznik

Home | Main Index | Thread Index | Old Index