NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

puc(4) com(4) on Soekris net4501?

Not really a NetBSD question except that it's what I'm using.

I got it in my head to see if I could make one of my net4501s fairly
bristle with serial ports with an eye toward being a console server.

I have a NetMOS 9685-based PCI 2-port serial card.  It's "universal" so
should work in a 3.3V-only PCI system like the net4501.  I removed the
net4501 from its case so I could plug the card in for testing.  A GENERIC
kernel sees the card and each of the serial ports (show up at com3 and
com4).  After making enough extra device nodes, 'getty' initialises them.

I am unable to get any meaningful response from them.  One port seems
completely unresponsive.  The other produces one character of garbage
(probably a transient from plugging in the cable) and is otherwise
similarly unresponsive.

I have another of these cards which I know works, but it's in a
conventional PC with 5V PCI.   I'm using a DB9-RJ11 adapter for the
serial line.  I know it works since I moved it over from the net4501
console port to test the add-on card.  (It has DTR->CD,DSR jumpered.)

(Just to make sure something worked in the PCI slot, I checked a
couple of ethernet cards and they worked fine.)

Has anyone else tried using such a setup, or a similar setup?  If so,
and it works, what PCI serial card did you use?

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index