NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re[2]: How to install rxvt-unicode-256color termcap entry on machine without X

Date:    Thu, 29 May 2014 23:48:03 +0100
From:    atomicules <>

|>  Hi Gerard,
|>  On 29-May-2014 15:17:31, Gerard Lally wrote:
|>  >Is there a way of installing
|>  >the terminfo or termcap entry for this terminal in the database?
|>  Not that I know of. I.e. I couldn't figure out a way to append to
|>  the database:
|>  But... you can create a ~/.terminfo.cdb file that contains the
|>  necessary info for the user of interest.
|>  >I tried the command below, as recommended on the urxvt website, but I
|>  >still get an error:
|>  >
|>  >REMOTE=myremoteserver.domain
|>  >infocmp rxvt-unicode | ssh $REMOTE "mkdir -p .terminfo && cat >/tmp/ti
|>  >&& tic /tmp/ti"
|>  I imagine this wants to be something like:
|>  infocmp rxvt-unicode | ssh $REMOTE "cat >~/.terminfo && tic
|>  ~/.terminfo"
|>  (Must be someway to get rid of cat from there?)

Hi again, and thanks for your help. I spent some time trying this and
got no further. Pulling my hair out at this stage.

First of all I created a terminfo source file on the Slackware machine
with rxvt-unicode-256color installed:

infocmp -I rxvt-unicode-256color > rxvt-unicode-256color.terminfo

I copied this terminfo source file to my home directory in NetBSD and
ran tic on it:

tic -s rxvt-unicode-256color.terminfo.

This created a .terminfo directory in HOME, and a subdirectory r with a
single file in r called rxvt-unicode-256color. No cdb extension in other
words. But running tic on the source file seems to succeed: it reports
that it added 1 entry to the database.

When I connect to NetBSD using rxvt-unicode-256color (whose TERM
variable is rxvt-unicode-256color) I still get an error running top to
the effect that there is no termcap entry for rxvt-unicode-256color.

Very frustrating.

Gerard Lally <>

Home | Main Index | Thread Index | Old Index