NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Can't get wpa_supplicant to work on NetBSD 5.0.2

On Thu, Apr 15, 2010 at 07:50:38AM -0600, Sverre Froyen wrote:
> On Thu April 15 2010 06:52:24 you wrote:
> > Trying to connect to my WPA2 wireless network using wpa_supplicant on a
> > fresh install of NetBSD 5.0.2. Connecting to this network with
> > wpa_supplicant works fine on Debian (although the configuration is a
> > little different, it uses debian's /etc/network/interfaces). Here's what I
> > did on NetBSD:
> > 
> > Used wpa_passphrase to create /etc/wpa_supplicant.conf (then added the
> > first two lines myself to get wpa_cli working):
> > 
> >     ctrl_interface=/var/run/wpa_supplicant
> >     ctrl_interface_group=wheel
> >     network={
> >             ssid="My_SSID"
> >             #psk="my passphrase"
> >             psk=fa68eac...
> >             }
> You have two lines for psk. I believe you need quotes around the value so the 
> second line is incorrect.

Unfortunately not. My network={ block is exactly as generated by the
wpa_passphrase program that comes with wpa_supplicant. The first psk
line is commented out, the second specifies the psk encrypted and should
not have quotes.

> For WAP2, I use the following config (on current) 
> with good results:
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=wheel
> network={
>         ssid="xxxxx"
>         scan_ssid=0
>         proto=RSN
>         key_mgmt=WPA-PSK
>         auth_alg=OPEN
>         psk="yyyyy"

I gave these settings a try but got exactly the same result: stuck at
ASSOCIATING. The wiki page
( suggests another
different set of configurations for WPA2 and those also produce the same
result. From reading the wpa_supplicant docs I think I should only have
to specify the ssid and psk and it should work, and that's what worked
in Debian.

This is my first ever NetBSD install so I could certainly be missing
something, but I can't imagine what. I think I may have hit a bug with
the version of wpa_supplicant in NetBSD 5.0.2.

Thanks anyway

Home | Main Index | Thread Index | Old Index