NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Can't get wpa_supplicant to work on NetBSD 5.0.2

Trying to connect to my WPA2 wireless network using wpa_supplicant on a
fresh install of NetBSD 5.0.2. Connecting to this network with
wpa_supplicant works fine on Debian (although the configuration is a
little different, it uses debian's /etc/network/interfaces). Here's what I
did on NetBSD:

Used wpa_passphrase to create /etc/wpa_supplicant.conf (then added the
first two lines myself to get wpa_cli working):

            #psk="my passphrase"

When I run wpa supplicant (wpa_supplicant -i ipw0 -c /etc/wpa_supplicant
-B), `wpa_cli status` always reports wpa_state=ASSOCIATING. It seems to
get stuck on ASSOCIATING.

Then I ran wpa_supplicant in the foreground with debugging on:

wpa_supplicant -i ipw0 -c /etc/wpa_supplicant.conf -d

Here's a sample of the output:

I've read what docs I can find on NetBSD + WPA and on wpa supplicant, but
I think I'm doing it right, I don't see what the problem is. The first
attempt to associate with the network seems to fail, it says
authentication timed out and then State: ASSOCIATING -> DISCONNECTED, it
then tries to associate again but this time says "already associated with
the selected AP", and this repeats forever,

Here are the docs that I've found:;a=blob_plain;f=wpa_supplicant/README

Home | Main Index | Thread Index | Old Index