NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Mounting a DVD

On Thu, 25 Feb 2010 12:02:41 -0600 (CST)
"Jeremy C. Reed" <> wrote:

> On Thu, 25 Feb 2010, Steven M. Bellovin wrote:
> > I'm trying, without success, to mount a DVD I burned on MacOS.  I've
> > tried mounting it as udf and as cd9660; both yield "invalid
> > argument" errors.  I have 
> > 
> >     file-system     UDF
> > 
> > in my kernel config.  Anything else I can try?
> "invalid argument" reminds me of my similar thread:
> I never solved it. My wife had the photographer email the photos 
> instead.
I figured out my problem, and the solution was even documented.  The
following text appears under NOTES in mount_hfs(8):

     Apple disk images (.dmg files) and hybrid CD-ROMs contain multiple
     parti- tions with an HFS+ file system on one of them.  Use
     apmlabel(8) to enter it into the disklabel and mount the resulting

When I ran 'apmlabel cd0', it said that cd0a had an HFS partition at
(synthetic, I think) cd0a.  I then did 'apmlabel -w cd0', after which I
could do 'mount -r -t hfs /dev/cd0a /mnt'.

I wonder if mount_hfs should look for such things and automatically

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index