NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-i386/40701: NetBSD 4.0.1 won't boot on old 486

>Number:         40701
>Category:       port-i386
>Synopsis:       NetBSD 4.0.1 won't boot on old 486
>Confidential:   no
>Severity:       critical
>Priority:       low
>Responsible:    port-i386-maintainer
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 20 16:50:00 +0000 2009
>Originator:     Dave Mischler
>Release:        4.0.1
won't boot
I don't know if anybody actually cares about this...

I have an old 486 system with 16 MB RAM.  It ran NetBSD 0.8 through 1.21 before 
being mothballed quite a few years ago.  I had a possible application for it 
and thought I would try NetBSD 4.0.1 on it.

This problem occurred when I tried to boot from the floppies, but I didn't know 
how to set up a serial console with the boot floppies.  I installed the system 
on an old hard disk using another machine and moved it to the problem system to 
get a console output.

Here is the console output:

>> NetBSD/i386 BIOS Boot, Revision 3.3
>> (builds@wb30, Tue Oct  7 21:54:59 PDT 2008)
>> Memory: 640/15360 k
Press return to boot now, any other key for boot menu
booting hd0a:netbsd - starting in 0
8538792+399556+350484 [410880+391979]=0x9a1040
WARNING: skipping large memory map entry: 0xff0002/0x200000a80000201/0x4
BIOS CFG: Model-SubM-Rev: fc-01-00, 0x70<KBDINT,RTC,IC2>
warning: too little memory available; have 651264 bytes, want 2097152 bytes
running in degraded mode
press a key to confirm

Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 4.0.1 (GENERIC.NOACPI) #0: Tue Oct  7 23:28:12 PDT 2008
total memory = 636 KB
rbus: rbus_min_start set to 0x20000000
avail memory = 504 KB

I assume that this is due to a BIOS problem that was worked around on the 
earlier versions that ran on this hardware.  I just thought that since the old 
CPU and small RAM are still listed as supported that somebody might want to 

Try to boot.


Home | Main Index | Thread Index | Old Index