Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: panic on zpool create

	hello David.  I wonder if you're running into another manifestation
of kern/54724, which shows zfs corrupting kernel memory in NetBSD-9.  I
show the problem having to do with xen, but I now believe the problem is
entirely with zfs and it was only coincidental that I ran into it with xen.
I left the machine in question, running zfs, for a month, doing  pretty
much nothing, but when I came back to it, I got weird messages like, proc
table is full.  There were a lot of process running, but I couldn't
determine which one was the one that was "really" stuck, since the number
of commands I could run was extremely limited.


On Jan 8,  1:07am, David Brownlee wrote:
} Subject: Re: panic on zpool create
} On Tue, 7 Jan 2020 at 12:48, David Brownlee <> wrote:
} >
} > On Tue, 7 Jan 2020 at 10:07, J. Hannken-Illjes <> wrote:
} > >
} > > For some reason locking the directory we want to mount on crashes.
} > >
} > > Anything special with the root on this machine?
} > >
} > > Does the directory (/angus_media I suppose) exist?
} >
} > /angus_media was present after the initial panic, removing it did not
} > seem to help.
} >
} > Ran a fsck -fyP on the system which picked up some issues, rebooted
} > and then tried again but the system still panics on zpool import (I'd
} > sent a follow up email noting that it appears the create is working
} > fine but the import panics, based on being able to create the pool on
} > another box running the same OS, but that pool then panics on import
} > on this box).
} >
} > The system is a Dell T320 with three filesystem on an LSI mfii0
} > controller, but I'm testing ZFS as the only two disk on the onboard
} > AHCI
} >
} > I'm going to try a current kernel in a bit (its a server and gateway
} > box so I'm trying to minimise downtime :)
} Ohhhh-Kaayyy... I have another data point.
} The panic does not occur in single user, but does when the system is running.
} Given this box takes approximately four minutes to complete POST to
} the point it actually starts to boot anything, and has the primary
} copy of quite a lot of data I value, my testing tomorrow is likely to
} be a little painful...
} Will update when I know more :)
} David
>-- End of excerpt from David Brownlee

Home | Main Index | Thread Index | Old Index