Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD current install issue

As Matthew suggested here, replacing my 9.0_BETA kernel with one from the -current distribution I was trying to install on a new disk worked perfectly.


On Nov 3, 2019, at 2:15 PM, matthew green <> wrote:

>> [1]   Bad system call         chroot /targetroot useradd -c
>> Has something changed between 9.0_BETA and -current that prevents this
>> from working?  Is there are different syntax or command I should be
>> using?
> yes.  a system call was added and when it's needed by code you'll
> get the above error.
> what you've been doing is technically "not supported", but worked
> for a long while recently by lucky accident.
> the only solutions are to avoid doing this.  ie, run a newer kernel
> when you want to run the newer binaries.  there _is_ a way to fix
> this in libc as well -- the system call failure could be caught and
> the old one used instead, which should avoid new bins on old kernels
> from crashing, but it is both not our policy and while this one case
> does appear to be only a small hack to fix, others are either not
> solveable or only with major effort (hence the policy.)
> i support this sort of simple hack to allow usage, but there was some
> pushback to implementing against policy.
> .mrg.

Home | Main Index | Thread Index | Old Index