Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD-current amd64 with dhcpcd connects only partially

    Date:        Tue, 13 Jun 2017 07:33:35 +0000
    From:        "Thomas Mueller" <>
    Message-ID:  <38.87.01815.C459F395@dnvrco-omsmta03>

  | I tried again with dhcpcd and did worse,

You are still not telling us what "worse" means, what was the state
before you did the manual configuration (but what comes later at least
tells us that the hardware is supported - though there is still a
slight question about broadcast - though if arp is working that should
be OK too.)

  | ifconfig re0 inet netmask 
  | route add default
  | and then was successful with "host"

This set of results indicates to me that some part of the network config
was not done, but that resolv.conf was made correctly (by dhcpcd).  That
would indicate to me that dhcpcd actually obtained answers from the dhcp
server, but was then unable to apply them on your system.

Check the dhcpcd config and make sure everything is correctly installed,
aside from speaking the DHCP protocol, almost everything else is done by
running scripts.   If the script is not present, or is not working
correctly, then dhcpcd will be unable to configure the system.

Look for /libexec/dhcpcd-run-hooks (which should be executable) and
/libexec/dhcpcd-hooks/* which should have a bunch of files that should
be readable (do not need 'x' not that it would hurt.)   I'm not sure
just where the ifconfig's get done though.  Roy?

  | Using dhcpcd or dhclient makes me rusty on directly setting internet
  | interface; any suggestions for improvement on what I did are welcome.

That was fine.

  | I think I could also have expressed netmask as 0xffffff00 or ...
  | inet ?

Either of those would work.


Home | Main Index | Thread Index | Old Index