Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: wm devices don't work under current amd64


Sorry for the long long delay...

On 2016/07/06 15:55, Masanobu SAITOH wrote:
>   I got a Latitude E6400 via an auction. I tried -current and it
> worked with MSI. While checking your dmesg, I noticed that you
> didn't use ACPI. I tried without ACPI and I could reproduce the
> problem. Without ACPI, any ioapic isn't attached. knakaraha said
> it might be the reason of the problem. Perhaps the problem is
> not only for Latitude E6400 but for all systems which don't use
> ACPI and use MSI/MSI-X. It can be fixed.

I borrow Latitude E6400 from msaitoh@n.o, and test below commit.

The wm works well without ACPI.
# Thank you nonaka@n.o

Could you try latest kernel?


Internet Initiative Japan Inc.

Device Engineering Section,
IoT Platform Development Department,
Network Division,
Technology Unit


Home | Main Index | Thread Index | Old Index