Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: USB serial problems

Thomas Klausner <> writes:

> I wanted to look at the serial console of a second machine, so I
> plugged in a USB serial dongle into my NetBSD (7.99.38/amd64):
> uftdi0 at uhub4 port 3
> uftdi0: FTDI FT232R USB UART, rev 2.00/6.00, addr 3
> ucom0 at uftdi0 portno 1

Beware the the word floating around on the Interwebs is that there are a
lot of counterfeit FTDI chipsets out there.  Apparently they mostly
work, and the angst is around how official binary FTDI drivers behave.
Probably this is not your issue.

> Then I looked at ucom(4) and saw that the first mentioned entry is
> /dev/dtyU?, so I set up 'minicom -s' using that device. Then I
> connected using minicom. The screen stayed empty, and the process was
> unkillable. I also tried 'cu -l /dev/dtyU0' which had the same result.
> (Even though there should have been something visible on the serial
> line.)

dtyU0 is the right file.  ttyU0 and dtyU0 are for the same device, but
dty is a dialout device that does not block waiting for carrier detect,
vs tty that by default blocks opening until CD is asserted.  (Back when
I was young, we had 300 baud modems, with dialin from terminals and
dialout for uucp!)

I've done what you describe with usb/serial dongles, often with uplcom.

> At the same time, the USB keyboard and USB mouse stopped working,
> without anything visible in dmesg.
> I wanted other processes to finish before rebooting, so I waited.
> 4 hours later I saw the following in the kernel log:
> ehci_sync_hc: cv_timedwait() = 35
> 4 hours later I tried rebooting, but had to press the reset button,
> 'shutdown -r' didn't work.
> Should I have used /dev/ttyU0 instead?
> I find it worrying that the USB mouse and keyboard stopped working
> without any kernel messages, and that the processes hung unkillably.

I think you are running into either

  really serious bugs in our kernel, or

  a broken device that is causing way more trouble than it should

Did you remove the serial dongle?  I have found that at times, pulling a
troublesome USB device resolves things.

Did you try on a netbsd-7 system?

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index