Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

USB serial problems


I wanted to look at the serial console of a second machine, so I
plugged in a USB serial dongle into my NetBSD (7.99.38/amd64):

uftdi0 at uhub4 port 3
uftdi0: FTDI FT232R USB UART, rev 2.00/6.00, addr 3
ucom0 at uftdi0 portno 1

Then I looked at ucom(4) and saw that the first mentioned entry is
/dev/dtyU?, so I set up 'minicom -s' using that device. Then I
connected using minicom. The screen stayed empty, and the process was
unkillable. I also tried 'cu -l /dev/dtyU0' which had the same result.
(Even though there should have been something visible on the serial

At the same time, the USB keyboard and USB mouse stopped working,
without anything visible in dmesg.

I wanted other processes to finish before rebooting, so I waited.

4 hours later I saw the following in the kernel log:
ehci_sync_hc: cv_timedwait() = 35

4 hours later I tried rebooting, but had to press the reset button,
'shutdown -r' didn't work.

Should I have used /dev/ttyU0 instead?

I find it worrying that the USB mouse and keyboard stopped working
without any kernel messages, and that the processes hung unkillably.



Home | Main Index | Thread Index | Old Index