Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ATF tests still failing to complete within 2 hours on amd64

On Thu, Dec 01, 2011 at 09:41:02AM +0200, Andreas Gustafsson wrote:
 > > When I run them as individual test cases rather than in sequence, some
 > > of them work fine; then others fail because rump processes from earlier
 > > cases are dangling.  Others do seem to take a very long time but finally
 > > complete.
 > Strangely, amd64 and i386 are behaving very differently - on i386, the
 > tests are not timing out, and there are no dangling rump processes,
 > just a bunch of failing networking related tests.  To verify that no
 > rump processes are dangling, I'm now running "ps -glaxw" after the
 > tests on my own test server, like at the end of this log:

Based on this report I tried building i386 instead of amd64 to run
tests on, and got this:

avail memory = 15080 KB
Kernel RNG "entropy pool" runs test FAILURE: too many runs of 1 0s (2696 > 2685)
panic: rnd: entropy pool failed statistical test
fatal breakpoint trap in supervisor mode
trap type 1 code 0 eip c02695b4 cs 8 eflags 282 cr2 0 ilevel 8
Stopped in pid 0.1 (system) at  c02695b4:       popl    %ebp

Only happened once, but given that other people have reported this
panic in chat I think that test may need its tolerance loosened. :(

David A. Holland

Home | Main Index | Thread Index | Old Index