tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Remove of Ruby 1.9.2 support

On Sun, 16 Sep 2012 11:57:02 +0900, David Holland 
<> wrote:

On Sun, Sep 16, 2012 at 11:49:02AM +0900, Takahiro Kambe wrote:
 > > Shouldn't this be done *after* branching rather than before?
 > Then, it would be difficult to maintain pkgsrc's branch.

Only if there's any actual maintenance that needs to be done. Leaving
an old package alive on the branch (and ignoring it there) doesn't
cost any more than removing it, and it's better for people who want
some time to migrate or finish migrating.

Before pkgsrc-2012Q1, default ruby was switched to 1.9.3.
I feel that a half year is sufficient for migration.

Also theoretically we're supposed to announce package removals one
full quarterly branch ahead of actually doing them.

For this case, ruby-1.9.2 v.s. 1.9.3, it is micro version differ.
PR 39890?

however, as far as I'm concerned it's ultimately up to you; if it
weren't for all the work you do we probably wouldn't have ruby

OBATA Akio /

Home | Main Index | Thread Index | Old Index