tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Remove of Ruby 1.9.2 support

In message <>
        on Sun, 16 Sep 2012 02:57:02 +0000,
        David Holland <> wrote:
> On Sun, Sep 16, 2012 at 11:49:02AM +0900, Takahiro Kambe wrote:
>  > > Shouldn't this be done *after* branching rather than before?
>  > Then, it would be difficult to maintain pkgsrc's branch.
> Only if there's any actual maintenance that needs to be done. Leaving
> an old package alive on the branch (and ignoring it there) doesn't
> cost any more than removing it, and it's better for people who want
> some time to migrate or finish migrating.
Because I must check Ruby and Ruby on Rails combination to build fine.

        Ruby:           1.8, 1.9.2, 1.9.3
        Ruby on Rails:  3.0, 3.1, 3.2

So, there are 9 combination.  Although I have sown, I want to reduce
the cost.  (Ruby on Rails has another problem...)

> Also theoretically we're supposed to announce package removals one
> full quarterly branch ahead of actually doing them.
Actually, was it done by branch announce?

> however, as far as I'm concerned it's ultimately up to you; if it
> weren't for all the work you do we probably wouldn't have ruby
> packages...

Takahiro Kambe <>/<>

Home | Main Index | Thread Index | Old Index