tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: perl 5.10.0 and Attribute-Handers

>       p5-Attribute-Handlers is incompatible with 5.10.0 - a good
>       test for this is to install p5-Test-Class and run:
>               'perl -e use Test::Class'
>       The obvious option is to adjust the DEPENDS to something like:
> {p5-Attribute-Handlers>=0.78,perl>=5.10.0}:../../devel/p5-Attribute-Handlers
>       Is it worth having a more generic way of handling this?

Hmm, yes, I've thought a bit about this when doing the various p5-*
package updates in pkgsrc: various modules are shipped as part of
perl, but the list and the versions versions vary between perl
releases.  In pkgsrc, typically those perl modules which are built-in
at the current version of perl are not listed with DEPENDS+= lines...
Also, as the above demonstrates, we have various built-in packages as
separate packages in pkgsrc, possibly because a newer version than
what is built-in to a given versio nof perl is needed.

I've been informed that p5-Module-CoreList makes it possible (e.g. via
the installed "corelist" script) to ask for which versions of perl
contained which versions of various modules ...and p5-Module-CoreList
is now itself an integral part of perl as of 5.10.0 :)


: {24} corelist -v 5.8.8 Module::CoreList
Module::CoreList undef
: {25} corelist -v 5.10.0 Module::CoreList
Module::CoreList 2.12
: {26} 

If this could be made to work, one need to be able to automatically
convert between the pkgsrc package name and the perl module name (drop
p5-, replace - with ::).

One could perhaps construct a P5_DEPENDS+= construct which used
corelist to eliminate dependencies on separate modules where the
built-in module satsfies the version number comparison?  (But this
also touches on the slightly different conventions for version
numbering between perl modules and pkgsrc packages.)


- Håvard

Home | Main Index | Thread Index | Old Index