tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: iscsi (initiator) unstable

I stand corrected. Looks like a commit from 2012-12-29 broke iscsi.
I have opened a PR

2014-08-01 17:09 GMT+02:00 Zafer Aydoğan <>:
> I have traced it back to 6.99.15.
> The problems disappear with 6.99.15.
> The in-kernel iscsi code did not change between
> 6.99.15 till now, which means that
> changes in the file system code in that
> timeframe are very likely responsible
> for the problems.
> Z.
> 2014-07-06 15:20 GMT+02:00 Zafer Aydoğan <>:
>> Hello List,
>> I am new to the iscsi world and I am experiencing some difficulties getting
>> iscsi to work reliably with NetBSD without knowing the core reason.
>> I hope to figure it out and to fix the issues with this discussion.
>> Status Quo:
>> I have a server running 6.99.45 amd64 very smoothly and I have an
>> iscsi target in
>> the same network that I can connect to as described in iscsictl(8).
>> After the logging in the sd0 disk device is present (or dk0 when
>> formatted with gpt)
>> and I can successfully newfs and mount the disk.
>> Everything looks fine to this point.
>> But the trouble starts as soon as I am writing data to the new storage.
>> Copying files or creating a big sparse file (50 GB) with dd will stop
>> the connection
>> to the storage quite fast. Disk activity with small files will delay
>> the interruption. The smaller the later.
>> There is no obvious network problem. I can see packets flying around
>> until they suddenly stop.
>> When the connection stops, then the process is in state tstile (ps D).
>> Everything else works fine. No crash or hang.
>> I can cd to /storage but writes to the disk will not complete and
>> wedge in tstile as well.
>> Additionally, I can re-establish the iscsi session, which will give me
>> a new disk device sd1, that I can mount and the story starts over.
>> Running iscsid in debug mode does not reveal anything special.
>> I tried different mount options (sync, log) because I thought
>> that syncing data to the disk was the reason. But no luck.
>> In my frustration I tried different file systems (lfs, ext2fs, v7fs),
>> but all of them will stop working sooner or later, except v7fs, but
>> thats due to the very low write-speed, I think.
>> Any help is appreciated.
>> Cheers,
>> Zafer

Home | Main Index | Thread Index | Old Index