tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Vnode API change: add global vnode cache

Alan Barrett <> wrote:
> On Mon, 07 Apr 2014, Mindaugas Rasiukevicius wrote:
> >Taylor R Campbell <> wrote:
> >>    What is "intern"?
> >>
> >> `Intern' means `lookup, or create and insert if not there'.
> >
> >The point being is that I do not find it meaningful/intuitive.  Many
> >other systems just use get().  If you want more accurate name, I suggest
> >conget() or something more meaningful.
> I would find "conget" confusing, while finding "intern" clear.
> Essentially, to "intern" a string or an external representation 
> of an an object, means to create an internal representation of 
> the string or object, or to find an already existing internal 
> representation of an identical object, and (usually) to return a 
> reference to that internal representation.  The wikipedia article 
> at <> is focused on 
> strings, but other objects can also be interned.

How about looking for precedents in the NetBSD source tree rather than
string manipulation in Java?  Nothing really uses "intern".  Perhaps not
a great naming, but other subsystems usually just use "get".

By the way, since LIPS was mentioned.. I actually suggested "conget"
while thinking of "cons".  It seems a bit easier to associate with
"construction".  The first thing which comes to mind when seeing an
"intern" is a "student". :)


Home | Main Index | Thread Index | Old Index