[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: Vnode API change: add global vnode cache
Taylor R Campbell <campbell+netbsd-tech-kern%mumble.net@localhost> wrote:
> Some specific comments:
> vcache_lookup(struct mount *mp, void *key, size_t key_len, struct
> vnode **vpp)
> Call it vcache_intern rather than vcache_lookup, since it inserts if
> not already there?
What is "intern"? Not intuitive. What is wrong with just vcache_get(),
or perhaps vcache_conget() for constructing-get? I would also prefer to
wrap the long line by using "vnode_t **vpp".
Main Index |
Thread Index |