tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Vnode API change: add global vnode cache

Mindaugas Rasiukevicius <> writes:

> Taylor R Campbell <> wrote:
>>    Date: Mon, 7 Apr 2014 16:56:58 +0100
>>    From: Mindaugas Rasiukevicius <>
>>    What is "intern"?
>> `Intern' means `lookup, or create and insert if not there'.
> The point being is that I do not find it meaningful/intuitive.  Many other
> systems just use get().  If you want more accurate name, I suggest conget()
> or something more meaningful.

Agreed that it may be surprising, but intern has a long history of that
kind of meaning in Lisp:

Attachment: pgpkc8tfqP6dh.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index