tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Decomposing vfs_subr.c

David Holland <> wrote:
>  > > 
>  > > - I think it should be vfs_vnode.c?
>  > 
>  > OK, unless somebody will come up with a better name.
> Since AIUI from chat this is going to contain the vnode lifecycle and
> code and not e.g. stuff like vn_lock, I think I'd prefer vfs_vncache.c.
> But, vfs_vnode.c is definitely better than vfs_node.c.

vfs_vnode.c then.

>  > Speaking of structural clean ups - I am thinking about moving vfs_*.c
>  > into a separate src/sys/vfs directory.  Given that clean code history
>  > of vfs_subr.c is already damaged (*cough*pooka*cough*) and decomposing
>  > will do more - it might be worth going all the way.
> Well, forcibly moving vfs_lookup.c right now (or anytime in the near
> future) would be a bad idea, so let's not. After that stuff
> stabilizes, perhaps we can. Though I'd kind of prefer having real
> rename support before launching on major reorgs.

I would say better move early, so the history of your further changes will
be preserved.  Rather than you make changes, and then history gets cut.


Home | Main Index | Thread Index | Old Index