tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Decomposing vfs_subr.c

On Wed, Mar 23, 2011 at 02:18:55PM +0000, Mindaugas Rasiukevicius wrote:
 > > > I would like to split-off parts of vfs_subr.c into vfs_node.c * and
 > > > vfs_mount.c modules.  Decomposing should hopefully bring some better
 > > > abstraction, as well as make it easier to work with VFS subsystem.
 > > > 
 > > > Any objections?
 > > 
 > > Sounds good to me.  Some comments:
 > > 
 > > - I think it should be vfs_vnode.c?
 > OK, unless somebody will come up with a better name.

Since AIUI from chat this is going to contain the vnode lifecycle and
code and not e.g. stuff like vn_lock, I think I'd prefer vfs_vncache.c.
But, vfs_vnode.c is definitely better than vfs_node.c.

 > > - Random thought: some day it would be nice to dump all the syscall code
 > >   into its own directory.
 > Speaking of structural clean ups - I am thinking about moving vfs_*.c
 > into a separate src/sys/vfs directory.  Given that clean code history
 > of vfs_subr.c is already damaged (*cough*pooka*cough*) and decomposing
 > will do more - it might be worth going all the way.

Well, forcibly moving vfs_lookup.c right now (or anytime in the near
future) would be a bad idea, so let's not. After that stuff
stabilizes, perhaps we can. Though I'd kind of prefer having real
rename support before launching on major reorgs.

David A. Holland

Home | Main Index | Thread Index | Old Index