tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Decomposing vfs_subr.c

Andrew Doran <> wrote:
> > I would like to split-off parts of vfs_subr.c into vfs_node.c * and
> > vfs_mount.c modules.  Decomposing should hopefully bring some better
> > abstraction, as well as make it easier to work with VFS subsystem.
> > 
> > Any objections?
> Sounds good to me.  Some comments:
> - I think it should be vfs_vnode.c?

OK, unless somebody will come up with a better name.

> - If there are mutexes, global data structures etc. consider making them
>   static.  File systems shouldn't be playing with this stuff in so far as
>   possible.

That is exactly what I am doing!

> - Much code in vfs_syscalls.c belongs in a vfs_mount.c.


> - Random thought: some day it would be nice to dump all the syscall code
>   into its own directory.

Speaking of structural clean ups - I am thinking about moving vfs_*.c
into a separate src/sys/vfs directory.  Given that clean code history
of vfs_subr.c is already damaged (*cough*pooka*cough*) and decomposing
will do more - it might be worth going all the way.


Home | Main Index | Thread Index | Old Index