tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: USB-related boot hang/"hang" on 5.0.1

On Oct 3, 2009, at 4:48 PM, Edward B. DREGER wrote:

MvE> Date: Sat, 3 Oct 2009 07:48:50 +0000 (UTC)
MvE> From: Michael van Elst

MvE> Some Linux users seemed to have the same problem and related it to
MvE> an old BIOS version (2.3.1). After a BIOS update the keyboard did
MvE> work.

2.5.0, but I see that Dell has a mysterious "Level of Importance:
Urgent" 2.5.3 since then.  I'll grab that.

GH> Date: Sat, 3 Oct 2009 17:50:08 +0200
GH> From: Geert Hendrickx

GH> I had a similar (the same?) problem on a Dell Inspiron PC and had to GH> remove all pckbc (ps/2 keyboard) related lines from my kernel config
GH> to avoid the problem (although the machine had no ps/2 ports
GH> either).  There was IIRC an interrupt storm going on, but I don't
GH> remember the details.  I think an UP kernel (or boot -1) worked,
GH> too.

No love from "boot -1".

Thanks for the "s/pckbc-related//g" tip.  I'll have to get another
sufficiently-new box together (unless 3.x will do the trick), then
cross-compile... so it'll be a while before I post success/failure
results for this.

Have you tried 'boot -c' and disable those ports?

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index