tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Subfile GSoC Mid-Checkpoint Status



On Jul 16, 2008, at 11:07 AM, Klaus Heinz wrote:

Adam Burkepile wrote:

int
subfile_open( const char* base_file , const char* base_file , int
open_flags)

int
subfile_fopen( int base_file , const char* base_file , int open_flags)

So they both return normal int file descriptors, just like open would.
The difference is how you are getting the basefile. subfile_fopen is
for a basefile that you already have open and have the fd.

Wouldn't "subfile_fdopen" be a better name than "subfile_fopen", then?
Similar to "fdopen" and "fopen" described in section 3 in the man pages.

ciao
    Klaus

That's what I had it named when I originally submitted the proposal for the project, but I believe someone suggested I change it subfile_fopen and my mentor agreed (I believe the reasoning was stat(2) stats a file by name and fstat(2) stats a file by fd). Perhaps I was unclear with the purpose of function. I will confer with my mentor again and discuss the naming of this function.


Adam Burkepile
sadpoti%gmail.com@localhost



Home | Main Index | Thread Index | Old Index