Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: First boot in domain0.


On Tue, Apr 27, 2004 at 08:37:10AM +0200, Juan RP wrote:
> dhclient was disabled because it didn't work for me. Also, there is a
> NetBSD/i386 GENERIC kernel without EISA/MCA/ISAPNPBIOS and ACPI enabled.

yeah, there seems to be a problem with dhclient's packets and Xen's
packet filter.  I know that dhclient works for Linux domains but I
haven't yet tried to figure out what's different.

> To load the NetBSD/Xen, enter the following in the grub shell:
> grub> configfile /grub/menu.lst

Can't you make it load this by default?  Grub seems to do so when installed
on a disk!?

> Christian if you could try it out and tell me why the xentools12 does not work
> when booting from the CDROM, I'd appreciate this.

You're missing "options DOM0OPS" in your kernel config file (at least according
to the one which is embedded in the kernel).  You probably missed it because my
patch only adds it to the XEN kernel config file and not to the GENERIC one.

All in all, having a Live CD is very neat, thanks!

In case you wanted to make a pkgsrc package for building Xen (hint! ;-)), below
is a patch to fix the problem where you have to pad the netbsd kernel so that
it's size is a multiple of 4.  I don't know how easy/hard it will be to make
Xen build on NetBSD and havent' tried yet.

--- ../../xeno-1.2.bk/xen/arch/i386/boot/boot.S 2004-03-11 23:16:13.000000000 
+++ arch/i386/boot/boot.S       2004-04-21 00:08:16.000000000 +0200
@@ -103,6 +103,7 @@
         sub     %ebx,%ecx                    /* %ecx = byte len of all mods */
         mov     $(MAX_DIRECTMAP_ADDRESS), %edi
         add     %ecx, %edi                   /* %edi = src + length */        
+        add            $3,%ecx
         shr     $2,%ecx                      /* %ecx = length/4 */
 1:      sub     $4,%eax                      /* %eax = src, %edi = dst */
         sub     $4,%edi

> The first lines I saw were from the linux kernel (WTF??!!), and later
> NetBSD/Xen ran perfectly (this is great, because I was trying it via
> MFS and root being an iso9660 image).
> Now, I'm not sure if the xen.gz file is the right one, because those
> Linux kernel messages were really strange, heh.

That's normal...  Xen uses quite a bit of code from Linux which is why its
startup looks a lot like Linux.  Just close your eyes until you (think
you'll) see green text ;-)

> Finally, I tried the tools included in xentools12 package from
> Christian, xc_dom_control.py didn't work, ballon coredumped when I
> ran it, I'm not sure if the problem was MFS or something like this.

There's no support for the balloon driver yet.


Home | Main Index | Thread Index | Old Index