Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem installing NetBSD 7.1.1 on my SparcStation 5

On 16 January 2018 at 13:27, Julien Savard <juliensavard17%gmail.com@localhost> wrote:
> Hi,
> I extracted the rootfs.tgz (
> ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-7.1.1/sparc/installation/netboot/rootfs.tgz)
> on the server. I did not run MAKEDEV (doesn't seems to be in rootfs.tgz ). I
> did also download the NetBSD Kernel, gunzip it, rename it simply "netbsd"
> and place it with the extracted rootfs on the root of the nfs share.
> But nevermind, I changed my NFS server from Solaris 10 x68_64  to a NetBSD 7
> x86_64 and Voila ! It worked ! No more "File too big" error.
> Pretty weird though..
> It seems there might be something not working between Solaris NFS Shares and
> NetBSD /dev in rootfs.tgz or it might also be the Solaris "tar" instead of
> the GNU tar ( just tought of that one ) not extracting the /dev as it
> should.
> So for now it'd say if anybody has the same issue, you might try to extract
> the rootfs with gtar instead of tar but if it doesn't work, simply don't use
> Solaris NFS for your netboot, use NetBSD or Linux ( haven't tried but I
> guess it should be working).

Glad its working for you! It does sound like an extraction issue.

If you still have the Solaris nfs export setup would you be willing to
just delete the contents of /dev and copy /dev/MAKEDEV from base.tgz
into it and try again - the client should automatically mount a tmpfs
on /dev/ and create the devices - then try mounting a filesystem.

As an aside NetBSD-8 is in BETA and if you wanted to have a play there
are builds in http://nycdn.netbsd.org/pub/NetBSD-daily/netbsd-8/ :)


Home | Main Index | Thread Index | Old Index