Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem installing NetBSD 7.1.1 on my SparcStation 5

I extracted the rootfs.tgz ( ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-7.1.1/sparc/installation/netboot/rootfs.tgz) on the server. I did not run MAKEDEV (doesn't seems to be in rootfs.tgz ). I did also download the NetBSD Kernel, gunzip it, rename it simply "netbsd" and place it with the extracted rootfs on the root of the nfs share. 
But nevermind, I changed my NFS server from Solaris 10 x68_64  to a NetBSD 7 x86_64 and Voila ! It worked ! No more "File too big" error. 
Pretty weird though.. 
It seems there might be something not working between Solaris NFS Shares and NetBSD /dev in rootfs.tgz or it might also be the Solaris "tar" instead of the GNU tar ( just tought of that one ) not extracting the /dev as it should.
So for now it'd say if anybody has the same issue, you might try to extract the rootfs with gtar instead of tar but if it doesn't work, simply don't use Solaris NFS for your netboot, use NetBSD or Linux ( haven't tried but I guess it should be working).

On Tue, Jan 16, 2018 at 7:19 AM, David Brownlee <abs%absd.org@localhost> wrote:
On 15 January 2018 at 17:47, Julien Savard <juliensavard17%gmail.com@localhost> wrote:
> Well I tried with :
> NetDBS 7.1.1
> NetBSD 7.1
> NetBSD 7.0.2
> NetBSD 6.1.5
> I'm starting to strongly suspect my NFS server on Solaris. Maybe there is
> something more to do on Solaris or something "not standard". I'll try to
> switch my NFS share from my Soalris server to a NetBSD or Linux server.

What are the details of the netbooted NetBSD - do you extract NetBSD
into a directory on the server and boot that as the nfs root?
Did you run MAKEDEV on the server or let the client create
dynamically? (latter is probably better).


Home | Main Index | Thread Index | Old Index