Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problem installing NetBSD 7.1.1 on my SparcStation 5

I'm trying to install NetBSD 7.1.1 on my old SparcStation 5. CD-ROM drive seems to be defective so I have no choice but to netboot it. I am already using a Solaris 10 x86 to netboot my Solaris server so I used it to also netboot NetBSD.
Netbooting seems to be working. I mean, it load everything and I get to the installation menu.The only problem I have at the beginning of the install. The installer try to partition, format and mount the disk. I alway get this error :

mount_ffs: Warnning realpth /dev/sd0a: File too large
mount_ffs:: /dev/sd0a on /targetroot: File too large

So I tried to get to the shell to mannually mount the disk but when I simply run a "ls -lh" in /dev I get the same eroor message for lot of devices :

ls: altmem0a: File too large
ls: altmem0b: File too large
ls: altmem0c: File too large
ls: altmem0d: File too large
ls: altmem0e: File too large
ls: altmem0f: File too large
ls: altmem0g: File too large
ls: altmem0h: File too large
ls: altmem1a: File too large
ls: altmem1b: File too large

And it goes the same for all these devices :

  • altmem0a
  • altmem1a
  • ccd0a
  • ccd1a
  • ccd2a
  • ccd3a
  • cd0a
  • fd0a
  • raid0a
  • raid1a
  • raid2a
  • raid3a
  • raid4a
  • raid5a
  • raid6a
  • raid7a
  • sd0a
  • sd1a
  • sd2a
  • sd3a
  • sd4a
  • xd0a
  • xd1a
  • xd2a
  • xd3a
I first thought it might be because it was mounted via NFSv2 however I verified that point :

soqc1-jumpstart1:/srv/netbsd/netboot on / type nfs (root file system, fsid: 0xb01/0x70b, reads: sync 0 async 0, writes: sync 0 async 0, [nfs: addr=, port=2049, addrlen=16, sotype=2, proto=0, fhsize=0, flags=0x8280<noconn,nfsv3,resvport>, wsize=8192, rsize=8192, readdirsize=8192, timeo=300, retrans=10, maxgrouplist=16, readahead=2, leaseterm=0, deadthresh=9])
mfs:7 on /tmp type mfs (synchronous, local, fsid: 0xff01/0x78b, reads: sync 58 async 0, writes: sync 18 async 18, [mfs: base=0xedefc000, size=1048576])

I also created a 2.2 Gb file using "dd if=/dev/zero of=zero.txt" and there is no problem when I run a "ls -lh" in the directory where it is.

Does anybody ever had this weird problem ?

Home | Main Index | Thread Index | Old Index