Port-prep archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 7.1 on a IBM 43P, 7248-132

Finally have a working firmware for the SCSI2SD device (replaces the SCSI2 HDD). This firmware works with the 7248-132, but in general probably supports anything using a Symbios Logic 53c810 (fast scsi) controller.

If you've been able to load NetBSD on your machine, have you had any trouble with the integrated ethernet freezing the machine when trying to bring up the interface?
"ifconfig pcn0 up" will cause my machine to lock up.

On 09/12/2017 03:49 PM, T wrote:
No problem, attached are the two config files. If they don't show up, I can paste them into emails.
Some quick pointers on some differences from the generic config:
-WD is disabled. I originally tried to use IDE drives since the SCSI drives I have are somewhat loud. Could not get the system to boot off of them, so decided not to use them. You might be able to use IDE for secondary drives.
-Stripped out PCMCIA.
-Removed any options for PCI/ISA that are not specific to this system.
-There are options turned on for a PCI NIC and an ISA NIC.
-USB subsystem enabled.
-The boot device is specified as SD0 and using FFS. This was due to the boot process not automatically finding the root drive (still unsure of the root cause). This will allow the boot process to reach the login prompt without prompting for the root device.

On a side note, I'm working with the developer of a SCSI2 to SD card adapter to get it to work with the 7248. He frequently provides updates for the firmware so this may become an option if you want quieter solid state storage.

On 09/11/2017 09:37 PM, William Orr wrote:

I know this is quite some time later, but I'd be very interested in your
kernel config!!


On 07/22/17 02:55, T wrote:
Finally got this to work:

I had to recompile the kernel to add in support for a PCI NIC and PCI
USB card and took the opportunity to trim out some things that were not
needed or planned on being used (WD).

I was wrong about the 2MB limit but ended up making a small kernel to
put into the PReP partion based on the INSTALL_SMALL kernel config.

I can post the kernel config files if you would find it useful.

On 07/01/2017 01:34 AM, T wrote:
I'm using the integrated ncr53c810 SCSI-2 controller so it may not be
the same issue you are having.

Using sysinst_small.fs in the PReP partition allowed loading of the
boot loader. The boot process will proceed to a point where it
requires user input to specify a boot device because it does not find
one by default. Providing it "sd0" will allow for the generic kernel
to load (when going multi-user?) and provide the login prompt.

If I enter "boot -s" at the boot loader prompt (single user), it will
boot into sysinst.

sysinst.fs will boot when I network boot with BOOTP/TFTP. I have not
tried writing that into the PReP partition (as I did with the small
version) but I suspect it would work because it is less than 2MB in size.

sysinst_com0.fs used in the same way mentioned above will not work for
me. I have not tried sysinst_small_com0.fs in this manner.

On 06/30/2017 03:35 AM, Artyom Tarasenko wrote:
Interesting. At a first glance the log says that the scsi driver is
broken in the NetBSD 7+. I hit that problem in this thread:

Are you saying the very same NetBSD version works for you if you use a
smaller sysinit image?

On Fri, Jun 30, 2017 at 7:23 AM, T <bobs%thelibertytree.org@localhost> wrote:
The PReP partition was set to use 5MB (as recommended in the
and located in the first BIOS partition. Only the kernels 2MB or
less seem
to make it to the boot loader for me. The <2MB serial console
sysinit image
will make it to the boot loader if I put it into the PReP partition,
will not boot past that point as mentioned in this thread:

On 06/29/2017 03:32 AM, Artyom Tarasenko wrote:
Is it a general issue, or was the PReP partition just too small in

On Thu, Jun 29, 2017 at 10:15 AM, T <bobs%thelibertytree.org@localhost> wrote:
Found that the kernel size is the issue by using mkbootimage with
install_small.fs and dding that into the PreP partition and
getting that
boot. Will end up doing the small kernel work around mentioned in the
referenced email thread.

On 06/24/2017 06:37 PM, t wrote:
I'm trying to get NetBSD 7.1 working on a 7248-132 but cannot get
computer to boot from the SCSI disk after installation. Booting the install kernel over the network seems to work with BOOTP/TFTP. After
completing the installation process and restarting the machine, I
into the SMS and change the boot priority to boot from the SCSI disk
instead of the network. Upon restarting and completing the boot
the computer ends up at a black screen and blinking cursor.
I believe this issue may be related to this thread:

This is my first time installing NetBSD so it could also be

I've tried re-writing the generic kernel to the prep partition with
"mkbootimage" but that did not seem to work.
Any help would be appreciated.

One other thing I've noticed with this machine is interactions
with the
pcn0 device seem to occasionally lockup the machine. I originally
going to install the NetBSD binary packages from a NFS mount, but
system would lockup halfway through the installation of the second
package. I bypassed this issue by using the CDROM instead.

Home | Main Index | Thread Index | Old Index